Mitsubishi Outlander PHEV Forum
http://www.myoutlanderphev.com/forum/

Bad home charging brick/trickle charger
http://www.myoutlanderphev.com/forum/viewtopic.php?f=10&t=4302
Page 1 of 1

Author:  BenSushiPHEV [ Thu Mar 14, 2019 10:50 am ]
Post subject:  Bad home charging brick/trickle charger

Hi all. I haven't found any discussion about this. I apologize if I missed something.

I bought a new Outlander PHEV in the States about two weeks ago. I noticed something strange about my home charging brick/trickle charger. Everywhere I look, a full charge (from empty) with the trickle charger on a standard home outlet is supposed to take about 8 hours. However, when I plug my charger in and check the charge time estimator on the dash, it's often around 12-15 hours. When I use the home charging brick for my wife's 2015 Nissan Leaf, the charge estimator will be around 6-8 hours (at the same power outlet). I'm thinking that my charging brick may be defective. Has anyone else had similar experiences?

Thanks in advance!

Author:  yardbird88 [ Thu Mar 14, 2019 11:35 am ]
Post subject:  Re: Bad home charging brick/trickle charger

You need to change your charger from 8amp to 12amp. There is a button that you need to press at the charger every time, default is always 8amp.

Author:  BenSushiPHEV [ Thu Mar 14, 2019 12:09 pm ]
Post subject:  Re: Bad home charging brick/trickle charger

Thanks yardbird88. That worked. I had tried that before, but only when the J-1772 was plugged into the car.

Author:  yardbird88 [ Thu Mar 14, 2019 2:36 pm ]
Post subject:  Re: Bad home charging brick/trickle charger

BenSushiPHEV wrote:
Thanks yardbird88. That worked. I had tried that before, but only when the J-1772 was plugged into the car.


change that to 12 amp Before plug in the J-1772

Page 1 of 1 All times are UTC - 8 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/