Mitsubishi Outlander PHEV Forum

It is currently Tue Oct 22, 2019 6:20 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Evse not working
PostPosted: Sat May 25, 2019 2:45 am 
Offline

Joined: Thu May 22, 2014 9:07 am
Posts: 562
Location: N Yorks, UK
After 5 years of regular use I am getting no lights on my granny charger. I'm planning to take it to a repair cafe today - I've tried searching and found a pic of the inside, a warning re a small black cable and that we might need a hair drier to get into it. Can anyone suggest what the fault will look like when we open it? Is it likely to be an obvious loose connection? I know this has been an issue - what have others found. My car is no longer under warranty.
Cheers
H

_________________
Outlander PHEV GX4H in blue from 25 June 2014

Image


Top
 Profile  
 
 Post subject: Re: Evse not working
PostPosted: Sun May 26, 2019 2:20 am 
Offline

Joined: Tue Aug 28, 2018 2:56 am
Posts: 22
Location: England - Somerset
Hi Hyper.

The usual fault is a break in the mains input cable side of the EVSE. This is often cause is hanging the EVSE by the plug rather than the lanyard. Most folks find that wiggling the input cable brings it back to life for a while.
Once you have it apart you can usually feel where the break is. Shorten and reconnect or fit a longer cable if that works for you. If you go this route buy a decent 13A plug, maybe MK - don't scrimp on this as it has to cope with 10A continuously and those from the Far East just won't.
Some basic soldering skills or a crimping tool will come in handy.

Plenty have carried this out. Take your time doing it.

Good luck.

_________________
Martin - 2017 G4H Amethyst Black Outlander PHEV.


Top
 Profile  
 
 Post subject: Re: Evse not working
PostPosted: Mon May 27, 2019 5:48 am 
Offline

Joined: Thu May 22, 2014 9:07 am
Posts: 562
Location: N Yorks, UK
Thanks Martin
We think this is the case as the lights occasionally come on when wiggling that end. I do always support the cable and never dangle it but hey... I’m planning to buy top notch lead and plug and take it back to the repair cafe and hope they can attach it for me. We couldn’t get into it at the weekend so I need to get the hairdryer out!
Cheers
H

_________________
Outlander PHEV GX4H in blue from 25 June 2014

Image


Top
 Profile  
 
 Post subject: Re: Evse not working
PostPosted: Wed May 29, 2019 1:17 am 
Offline

Joined: Mon Mar 12, 2018 2:18 am
Posts: 436
Location: Yorkshire end of M1, UK
There are a couple of videos on YouTube which may be of help: https://www.youtube.com/results?search_ ... ger+repair

_________________
2015 GX4hs since 03/18
2015 Renault Zoe R240 owner since 11/17

You may have speed, but I have momentum...


Top
 Profile  
 
 Post subject: Re: Evse not working
PostPosted: Sun Jun 02, 2019 2:31 pm 
Offline

Joined: Thu May 22, 2014 9:07 am
Posts: 562
Location: N Yorks, UK
That’s very helpful thank you

_________________
Outlander PHEV GX4H in blue from 25 June 2014

Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 8 hours [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
© Mitsubishi Outlander PHEV Forum - part of the MyElectricCarForums.com Group