Mitsubishi Outlander PHEV Forum

It is currently Fri Oct 18, 2019 6:07 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Ev service light and no engine power
PostPosted: Thu May 30, 2019 9:42 am 
Offline

Joined: Thu May 30, 2019 9:10 am
Posts: 10
Hi I have a 2019 2.4 litre phev recently the ev service light came on but would go out after restart garage confirmed no codes saved today whilst going up a hill in save mode the engine started pulsing with kw meter swinging plus and minus around the 5kw mark it felt like the engine was running out of fuel seconds after the yellow ev service light came on
Stopped turned off and on light went out later in save mode going up a hill engine started Reving up and down again and it felt like engine braking coming on and off yellow ev service light came on .instead of stopping and turning off I found that the car drove ok but even at 80mph the orange drive via the engine rather than battery never came on
Thus the rest of the day was spent with engine surging and light coming on going off if I left the car and even the odd transmission jerk (very un PHEV like)

Car is in to dealer tomorrow just a question anyone else with a 2.4 2019 model had similar problem.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 8 hours [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
© Mitsubishi Outlander PHEV Forum - part of the MyElectricCarForums.com Group