Page 1 of 1

MMCS keeps re-booting

Posted: Tue Apr 06, 2021 11:27 am
by WyckeWatcher
I have an Outlander PHEV bought in March 2015. All of a sudden, with no prior warning, my MMCS (SatNav/Display/Radio etc) keeps re-booting. This starts as soon as I press the Start button. It attempts to boot up. Sometimes it makes it as far as displaying the map, more often it doesn't. Very occasionally it will stay on for, maybe, 3 or 4 minutes. Sometimes, but not always, when it goes off there is a loud beep. Each time it goes off the running lights go off as well. None of this affects driving the car - everything else is working correctly.

When the MMCS goes off and, again, when it attempts to boot up I can hear the clicking of a solenoid. My guess is that there is a solenoid - or several - that operates after you press the Start button when you reach the 'Ready' state which turn on various functions that always come on at this stage. If this guess is correct, could it be that the solenoid turning the MMCS on has failed? If so, can anyone confirm this and tell me where it is and what I would need to replace it?

With thanks in advance.

Re: MMCS keeps re-booting

Posted: Tue Apr 06, 2021 1:54 pm
by SemaphoreSlim
The relay would probably kick on as soon as it starts to boot.

I don't think your relay has failed

I think it's far more likely that you have a head-unit or vehicle core unit failure of some sort (either hardware or possibly software).

But I'm a newbie to this car, so maybe someone else has a more accurate answer?