Posts: 3
Joined: Sun Oct 18, 2020 7:28 pm

MMCS map card error

Tue May 11, 2021 6:36 am

Hi all,

I have had my 2014 Japanese imported outlander phev for 6 months now, and everything have been working until this morning, all the sudden, the mmcs is stuck on this screen when the car is started.

I believe the translation for the message is "please insert the map sd card program into the map slot".

It would seem I need the map sd card to get past the issue, but on the other hand, I haven't had the card for the last 6 months and not once did I see this issue.

I have kept driving the car for the whole day and restarted the car at least 4-5 times, tried pressing all the buttons, but the issue persisted. This problem is now causing the mmcs to be unusable and I cannot change audio modes and look at system settings...etc

Has someone had similar experience? Any help or suggestion will be highly appreciated. Thanks
You do not have the required permissions to view the files attached to this post.

Posts: 606
Joined: Wed Sep 09, 2015 5:05 pm
Location: Australia

Re: MMCS map card error

Thu May 13, 2021 2:59 pm

First question:

Have you checked to make sure that the SD card is not in the map slot?

(Assuming you haven't removed it and discarded it.)

Next, you can buy these cards online or download the data and build your own.
2014 PHEV Aspire, Arctic Silver;
Black Interior;
Hayman Reese removable tow bar;
1.5kW Solar, grid connected.

Posts: 3
Joined: Sun Oct 18, 2020 7:28 pm

Re: MMCS map card error

Fri May 14, 2021 3:16 am

Thanks for your reply AndyInOz.

When I purchased the car 6 months ago, the map SD card never came with the car. And yes you are right, downloading the program and data and install it on my own sd card will be a thing to try.

Somewhat lucky for me, I called the dealer where I purchased the car from 6 months ago and let them know the situation, and they actually have the map SD card for the car that they forgot to give it to me. And once I obtained the car and inserted into the map slot, everything worked.

Apparently the on some models, the SRAM can run the program without the map card installed but once the 12V power is disconnected, it will require the MAP card to boot. While I have never disconnected the 12V battery, but this sort of explains why the MMCS was running fine for 6 months and this problem happened all the sudden.

Return to “General / Main Outlander PHEV Owners Forum”