Phone app won't connect to car

Mitsubishi Outlander PHEV Forum

Help Support Mitsubishi Outlander PHEV Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Fjpod

Well-known member
Joined
Nov 30, 2013
Messages
119
Location
NYC
I have a 2020 Outlander phev, USA. The app is pretty miserable but it used to work for me. I tried searching the forum but couldn't find a topic related to mine.

I had trouble with my phone and had to reset it. Since then I have not been able to reconnect my car to my phone. I followed all the steps in the manual. I took it to the dealer and about 5 different employees there could not do it either. They tried calling MM directly for me, but they got nowhere.

Has anyone here had this problem? Thanks in advance.
 
My phone had a complete factory reset. The Mitsubishi app was added again, but it will not connect to the car.
 
No, not the 'phone itself. Did you delete the 'phone record from the car's memory, as presumably you can't have the same IMEI registered twice?
 
Hi. Sorry for not getting back to all of you who were nice enough to respond.

Is there a specific place on the center console screen where you delete a phone?
 
No. There's a specific sequence to follow with the lock/unlock etc. You have been given a link to it above, and a quick google will also take you directly to Mitsubishi help pages where they give you a step by step.
 
Fjpod said:
Is there a specific place on the center console screen where you delete a phone?

Click on the link in the post by @ThudnBlundr
There are detailed instructions to reset the Wi-fi unit which will deregister all previously connected phones.
 
Not sure if it’s better to reply to this post with my similar issue or start a new one. I’m trying to de-register any previous phones.

My 2016 car has been patched to have the 14 digit WiFi password. I’m using the newer app, just downloaded.

I don’t get the second set of beep after 20 presses in - just silence.

https://www.richi.uk/p/mitsubishi-outlander-phev-faq.html#phevfaqE
When I try register phone, I get the beep as expected but then error 2101.

Are there any other things to try beyond faqE?
 
Not sure if it’s better to reply to this post with my similar issue or start a new one. I’m trying to de-register any previous phones.

My 2016 car has been patched to have the 14 digit WiFi password. I’m using the newer app, just downloaded.

I don’t get the second set of beep after 20 presses in - just silence.

https://www.richi.uk/p/mitsubishi-outlander-phev-faq.html#phevfaqE
When I try register phone, I get the beep as expected but then error 2101.

Are there any other things to try beyond faqE?
I started getting g the Error 2101 this past summer.

According to my Dealer Mitsubishi North America is having issues with the Network, In Canada and the USA.

Come on Mitsubishi, over 6 months and fi for this issue?

I am not impressed
 
Back
Top