Mitsubishi Outlander PHEV Forum

It is currently Sat Jul 20, 2019 2:19 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Heater not working
PostPosted: Mon Dec 17, 2018 4:14 am 
Offline

Joined: Mon Dec 17, 2018 3:55 am
Posts: 1
For a while now my heater will warm up the car for the first 20 minutes or so, then just cool air come through thereafter.

The dealer has had a look at the issue but to no avail.

Does anyone have a similar problem??


Top
 Profile  
 
 Post subject: Re: Heater not working
PostPosted: Fri Feb 15, 2019 10:10 pm 
Offline

Joined: Wed Feb 13, 2019 8:51 pm
Posts: 5
I do seem to have a similar issue with my 2018 Canadian model. I bought it used earlier this week. I think it has some correlation to when the ICE heater kicks in, at least in my case. Blows ice cold air while the ICE is running, then warms up when back to EV. Did you ever get your problem resolved?


Top
 Profile  
 
 Post subject: Re: Heater not working
PostPosted: Tue Apr 09, 2019 5:48 am 
Offline

Joined: Tue Apr 09, 2019 5:44 am
Posts: 4
Marvin089 wrote:
For a while now my heater will warm up the car for the first 20 minutes or so, then just cool air come through thereafter.

The dealer has had a look at the issue but to no avail.

Does anyone have a similar problem??


Hi.

Had my 65 plate GX4h for about 2 weeks now and I'm experiencing the exact same problem It's driving me nuts. Warms up for about 15-20 mins then goes cool. Even with the heating controls set at 28 degrees, I've measured the air temperature from the vents at 17/18 degrees. Seems to be when the electrical heater has turned off and it switches to ICE.

Has anyone resolved this?


Top
 Profile  
 
 Post subject: Re: Heater not working
PostPosted: Wed Apr 10, 2019 10:15 am 
Offline

Joined: Thu Oct 18, 2018 6:09 pm
Posts: 6
Are you using ECO mode? I found that in ECO mode, my 2018 PHEV (Canadian version) exhibits the similar heating issue.


Top
 Profile  
 
 Post subject: Re: Heater not working
PostPosted: Fri Apr 12, 2019 12:14 am 
Offline

Joined: Tue Apr 09, 2019 5:44 am
Posts: 4
vluong0403 wrote:
Are you using ECO mode? I found that in ECO mode, my 2018 PHEV (Canadian version) exhibits the similar heating issue.


Hi vluong. Thank you for your reply.

No, I'm using comfort mode. I had a similar thought and switched to comfort mode. Again this morning, after about 20 mins, the electric heater switched off and it went cool when on ICE heating. I actually found the cabin warmer if I turned the heater panel off.

Coming from a Ford vehicle where the heater would make you sweat, I'm a little disappointed to be honest.

May have to look at taking it to Mitsubishi and ask them to take a look.


Top
 Profile  
 
 Post subject: Re: Heater not working
PostPosted: Mon Apr 15, 2019 11:32 am 
Offline

Joined: Wed Feb 13, 2019 8:51 pm
Posts: 5
In my case, after taking mine in to the dealership for the 3rd time they found a crushed coolant line. 2018 Canadian model. I would check to make sure you don't have any kinks or take it in to get it looked at. The coolant lines that were crushed on mine were under the vehicle (not very protected), we figure it was done by a improperly placed hoist before I purchased it. They replaced the pipe and it heats great now. I also came from a "sweaty ford" and live in Winnipeg, Canada FWIW.


Top
 Profile  
 
 Post subject: Re: Heater not working
PostPosted: Tue Apr 16, 2019 12:37 am 
Offline

Joined: Mon Dec 03, 2018 8:47 am
Posts: 160
Location: Southern end of North Yorkshire, UK
On the UK PHEV Facebook group there's been a discussion recently about a filter inside a coolant pipe that can get clogged, leading to a lack of heating. It's a relatively easy job to clamp the coolant hoses, remove the filter and clean it, then refit.

_________________
2015 Mitsubishi Outlander PHEV GX4H (petrol/electric)
2008 Volkswagen Caravelle (diesel)
(recently departed - 2004 Subaru Outback 3.0Rn (LPG), 1991 Mitsubishi Pajero 2.5 LWB (WVO))


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 8 hours [ DST ]


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
© Mitsubishi Outlander PHEV Forum - part of the MyElectricCarForums.com Group